起步软件技术论坛
搜索
 找回密码
 注册

QQ登录

只需一步,快速开始

楼主: liangshaohua

[分享] App打包常见报错

  [复制链接]

9

主题

17

帖子

77

积分

初级会员

Rank: 2

积分
77
QQ
发表于 2016-3-3 10:18:25 | 显示全部楼层
D:\WeX5_V3.3\model\Native\wangyi\build\src\platforms\android\cordova\node_modules\q\q.js:126
                       throw e;
                             ^
   Error code 1 for command: cmd with args: /s,/c,ant,release,-f,D:\WeX5_V3.3\model\Native\wangyi\build\src\platforms\android\build.xml
****ERROR****: 子任务 "exec" 执行失败。
****ERROR****: 任务 "buildAndroid" 执行失败。
****ERROR****: 执行出错:
****ERROR****: 错误信息: exec returned: 1
****ERROR****: 如不能确定具体问题,可参考常见问题: http://bbs.wex5.com/thread-82002-1-1.html

这个是什么问题????????
回复 支持 反对

使用道具 举报

0

主题

245

帖子

494

积分

中级会员

Rank: 3Rank: 3

积分
494
QQ
发表于 2016-3-3 18:30:21 | 显示全部楼层
459857070 发表于 2016-2-22 15:08
请问这个怎么解决
插件 "com.justep.cordova.plugin.alipay" 参数如下:
****ERROR****: 子任务 "addPlugin ...

亲,人家不是说的很清楚了!你的那个alipay的插件有参数没设置!这在编译的时候是不允许的,所以报错!
回复 支持 反对

使用道具 举报

0

主题

245

帖子

494

积分

中级会员

Rank: 3Rank: 3

积分
494
QQ
发表于 2016-3-3 18:31:49 | 显示全部楼层
simon_xu_sh 发表于 2016-2-29 17:45
开始......
   
保存配置信息:

对于安卓我了解不多,但是应该是你的apk文件正在被使用,所以编译的时候无法清除这个文件,导致报错!
回复 支持 反对

使用道具 举报

0

主题

245

帖子

494

积分

中级会员

Rank: 3Rank: 3

积分
494
QQ
发表于 2016-3-3 18:36:00 | 显示全部楼层
xunchangguo 发表于 2016-1-18 16:17
楼主:问个问题,使用了第三方plugin,该plugin又使用了AFNetworking, 打包IOS时候,该如何处理 ...

如果说这个插件使用了AFNetworking,那么这个插件的作者自己就有配置的,不用开发者自己去注意这些!插件作者会将相应的AFNetworking文件导入,并且自己会在xml文件中填写相关配置,你不用去关心这些,除非这个插件自己本身有问题!
回复 支持 反对

使用道具 举报

0

主题

245

帖子

494

积分

中级会员

Rank: 3Rank: 3

积分
494
QQ
发表于 2016-3-3 18:39:55 | 显示全部楼层
Benio 发表于 2016-3-2 11:55
【Android打包报错】
debug:
   

你是不是打包的时候勾选了某些插件,然后这些插件需要填参数,而你填了“?????”,如果是这样的情况,将参数改成规定的格式就行了!
回复 支持 反对

使用道具 举报

0

主题

245

帖子

494

积分

中级会员

Rank: 3Rank: 3

积分
494
QQ
发表于 2016-3-3 18:43:29 | 显示全部楼层
285436322@qq.co 发表于 2016-2-18 16:34
开始......
   
保存配置信息:

你电脑上是不是自己装了cordova环境?我觉得你的问题是cordva环境太老了!这个插件对cordova版本有要求的!
回复 支持 反对

使用道具 举报

25

主题

1597

帖子

2625

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2625
发表于 2016-3-5 00:18:53 | 显示全部楼层
up
回复

使用道具 举报

3

主题

12

帖子

43

积分

新手上路

Rank: 1

积分
43
QQ
发表于 2016-3-8 18:42:52 | 显示全部楼层
郑峰次郎 发表于 2016-2-2 18:47
****ERROR****: 子任务 "updateSource" 执行失败。
****ERROR****: 任务 "updateProject" 执行失败。
****E ...

请问解决了吗?我也是这个错误
回复 支持 反对

使用道具 举报

23

主题

125

帖子

272

积分

中级会员

Rank: 3Rank: 3

积分
272
QQ
发表于 2016-3-9 11:22:26 | 显示全部楼层
楼主你好,iOS打包错误5,/Native/templates/advanced does not exist,请问一下有图吗? use `xcode-select --switch '中的解决方法,在Xcode中始终没有找到select,请指教一下,谢谢?还有Xcode7免真机调试必须使用5.2.1的版本吗?
回复 支持 反对

使用道具 举报

3

主题

12

帖子

48

积分

新手上路

Rank: 1

积分
48
QQ
发表于 2016-3-14 10:05:19 | 显示全部楼层
九月书生 发表于 2016-3-3 18:39
你是不是打包的时候勾选了某些插件,然后这些插件需要填参数,而你填了“?????”,如果是这样的情况 ...

問題已解決,是有些插件我沒有選上,也沒有填寫,不知道為什麼默認是????,每次編譯的時候需要去那裡取消裡面的內容
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|X3技术论坛|Justep Inc.   

GMT+8, 2017-1-24 23:20 , Processed in 0.171532 second(s), 23 queries .

Powered by Discuz! X3.1

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表