起步软件技术论坛
搜索
 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 22154|回复: 28

[公告] BeX5 V2.7开发的系统部署到BeX5 V3.1或V3.2版本

  [复制链接]

20

主题

119

帖子

724

积分

内部用户

积分
724
发表于 2015-6-15 13:28:15 | 显示全部楼层 |阅读模式
【部署步骤】
1、联系商务人员获取 BeX5 V3.1或V3.2的版本;
2、下载 BeX5_V3.X版本5.2兼容包
3、将  BeX5版本5.2兼容包 解压覆盖至 BeX5 V3.1或V3.2版本 中对应目录;
4、下载文件,替换至BeX5 V3.1或V3.2版本的runtime\UIServer\WEB-INF目录下,用于更换为5.2.7的标准门户登陆地址。
5、将X5.2.7版本中Biz和UI目录下的应用目录(除system、sa、portal、portal2等版本自带目录)对应复制到BeX5 V3.1或V3.2版本的Biz和UI目录下。
6、数据库升级:根据数据库升级说明进行升级。
X5.2.7升级X5 V3.0:下载地址
BeX5 V3.0升级BeX5 V3.1:下载地址
BeX5 V3.1升级BeX5 v3.2:下载地址

如果是升级到V3.2版本注意:
        此版本对增强MD5密码加密,如果使用增强加密的特性执行升级包中update.bat
        如果不使用增强加密的特性执行升级包中update_noUpdatePWD.bat,并且需要把/BIZ/system/config/sys.config.m文件中的
          <config name="passwordSalt" value="http://www.justep.com"/>注释掉

   如果同时用了即时通讯messager就不能使用增强加密的特性


完成以上步骤,即完成升级。

详细升级部署步骤可参看培训视频:下载地址

【访问注意事项】
1、5.2.7的标准门户登陆   http://IP:port/x5
2、5.2.7的经典门户登陆   http://IP:port/x5/portal/login.w
3、5.2.7的手机门户登陆   http://IP:port/x5/m

【开发注意事项】
开发使用版本既可以使用“V3.1+5.2兼容包”也可以继续使用V5.2.7的开发版。
1、如果使用V5.2.7开发版继续开发,将开发后的资源部署到V3.1推广版中进行运行。
2、如果使用“V3.1+5.2兼容包”,那么要使用studio5.2目录下的studio.exe。


评分

参与人数 1威望 +10 收起 理由
Masion + 10 赞一个!

查看全部评分

0

主题

2

帖子

20

积分

新手上路

Rank: 1

积分
20
QQ
发表于 2015-6-16 22:31:10 | 显示全部楼层
4、下载文件,替换至BeX5 V3.1版本的runtime\\UIServer\\WEB-INF目录下,用于更换为5.2.7的标准门户登陆地址。

下载 文件?? where?
回复 支持 反对

使用道具 举报

19

主题

114

帖子

692

积分

高级会员

Rank: 4

积分
692
QQ
发表于 2015-6-23 14:13:42 | 显示全部楼层
BeX V5.2.7开发的系统部署到BeX5 V3.1有什么好处?
UI方面能自动向V3.1兼容吗?
这个人很懒,什么也没留下
回复 支持 反对

使用道具 举报

11

主题

163

帖子

761

积分

高级会员

Rank: 4

积分
761
QQ
发表于 2015-6-26 12:37:56 | 显示全部楼层
看到
回复

使用道具 举报

112

主题

304

帖子

778

积分

高级会员

Rank: 4

积分
778
QQ
发表于 2015-6-30 14:18:17 | 显示全部楼层
下载   web.xml (7.67 KB, 下载次数: 18) 文件,替换至BeX5 V3.1版本的runtime\\UIServer\\WEB-INF目录下,用于更换为5.2.7的标准门户登陆地址。


这样的话,在v3.1下开发的内容岂不是看不到了?   这里登录进取的全是2.7的东西,如果要访问3.1里开发的东西怎么办?
回复 支持 反对

使用道具 举报

32

主题

91

帖子

397

积分

中级会员

Rank: 3Rank: 3

积分
397
QQ
发表于 2015-7-21 14:27:05 | 显示全部楼层

原来还有个逗比在帮着顶
回复 支持 反对

使用道具 举报

0

主题

0

帖子

3

积分

新手上路

Rank: 1

积分
3
QQ
发表于 2015-8-5 04:56:31 | 显示全部楼层
我想知道怎么找应用平台啊
回复 支持 反对

使用道具 举报

0

主题

3

帖子

12

积分

新手上路

Rank: 1

积分
12
QQ
发表于 2015-8-5 15:47:59 | 显示全部楼层
挺全的,学习了。。。
http://www.99tw.com
回复 支持 反对

使用道具 举报

35

主题

135

帖子

334

积分

中级会员

Rank: 3Rank: 3

积分
334
QQ
发表于 2015-8-18 11:40:04 | 显示全部楼层
群主你好,我按照你们发布的视频做v5.2.7升级到v3.2版本,升级的时候用v5.2.7门户登录的时候,代码程序没有任何问题,v5.2.7开发的功能也可以正常使用。但是用V3.2门户的时候,就出现问题了。表现为:点击标准自带的菜单没有问题,但是点击在v5.2.7开发的功能的没有响应,后台也没有报错,但是菜单也没有跳转,请问如何定位问题?
回复 支持 反对

使用道具 举报

408

主题

1117

帖子

3720

积分

论坛元老

Rank: 8Rank: 8

积分
3720
QQ
发表于 2015-8-27 13:25:51 | 显示全部楼层
从3.1升级到3.2的时候,

执行update_noUpdatePWD, 报错,
错误: 找不到或无法加载主类 ;..update.jar;..lib.ojdbc14.jar;..lib.db2jcc.jar;..li
b.db2jcc_license_cu.jar;..lib.mysql-connector-java-3.1.12-bin.jar;..lib.jtds-1.2
.jar;..lib.dom4j-1_6_1.jar;..lib.jaxen-1_1_beta_9.jar
请按任意键继续. . .



回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|X3技术论坛|Justep Inc.    

GMT+8, 2019-7-21 14:56 , Processed in 0.148003 second(s), 27 queries .

Powered by Discuz! X3.1

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表