起步软件技术论坛
搜索
 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 2254|回复: 0

关于数据库DB2的设置

  [复制链接]

12

主题

2618

帖子

2835

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2835
发表于 2013-8-12 16:50:03 | 显示全部楼层 |阅读模式
1. X5支持DB2的9.7.4版本(即9.7.0的第四个补丁)及后续版本;
2. DB2的企业版本需要设置成ORACLE兼容模式,具体命令如下:
db2的企业版本(v9.7.0.8或v9.7.600,或其它),在select case中使用参数时,会报-418的错误(但在Express-C的v9.7.400中,是正常的)
解决方案:设置成oracle兼容模式
关键指令:
db2set DB2_COMPATIBILITY_VECTOR=ORA
db2stop force
db2start

高级模式
B Color Image Link Quote Code Smilies

本版积分规则

小黑屋|手机版|X3技术论坛|Justep Inc.    

GMT+8, 2020-2-26 12:17 , Processed in 0.064498 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表